Forum Archive-Host

Vous n'êtes pas identifié.

#1 25-02-2014 18:59:17

gilbert290
Membre
Date d'inscription: 18-08-2012
Messages: 63
Site web

Protection anti hotlink

Bonsoir,

J'ai mis le code suivant dans le .htacess pour protéger mes photos contre le hotlink.
RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?gilbertphotos.fr/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?gilbertphotos.fr$      [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?google.com/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?google.com$      [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?google.fr/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?google.fr$      [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?images.google.com/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?images.google.com$      [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?images.google.fr/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?images.google.fr$      [NC]
RewriteRule .*\.(jpg|jpeg|png|gif)$ http://gilbertphotos.fr [R,NC]

Le code fonctionne bien, mais pas pour toutes les photos, beaucoup de mes photos sont bien protégées, mais beaucoup d'autres ne le sont pas.
J'ai vérifié sur ce site en bas de la page:  http://altlab.com/hotlinking.html

Je retrouve donc beaucoup de photos 'hotlinké' sur http://www.picstopin.com, qui semble être une référence dans ce domaine.
D’où ma question, pourquoi ça ne fonctionne pas avec toutes mes photos?
Une erreur dans mon code?
Merci d'avance.
Bonne soirée.

Dernière modification par gilbert290 (25-02-2014 19:28:49)

Hors ligne

 

#2 27-02-2014 11:24:32

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5038
Site web

Re: Protection anti hotlink

Bonjour,

Je peux avoir un exemple d'images qui sont protégées et d'autres qui ne le sont pas ?


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

#3 27-02-2014 19:09:17

gilbert290
Membre
Date d'inscription: 18-08-2012
Messages: 63
Site web

Re: Protection anti hotlink

Bonsoir,

En fait je n'ai plus le même fonctionnement que hier soir.

Par exemple celle ci est protégée, mais ne s'ouvre plus sur le blog,c'est la première en page d'accueil:
http://www.gilbertphotos.fr/wp-content/ … ygne10.jpg

Et celle ci n'est pas protégée, et s'ouvre bien sur le blog, la deuxième en page d'accueil:
http://www.gilbertphotos.fr/wp-content/ … -foret.jpg

Et d'autres protégées hier ne le sont plus...le code dans le .htaccess est toujours le même pourtant.

Et je viens de tester à l'instant, et la première n'est plus protégée, et du coup s'ouvre de nouveau!!!

En fait je n'y comprends plus rien...

Hors ligne

 

#4 28-02-2014 23:27:54

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5038
Site web

Re: Protection anti hotlink

Vous pouvez essayer avec ce tuto ?
http://blog.aube-nature.com/protection- … =undefined


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

#5 01-03-2014 09:59:10

gilbert290
Membre
Date d'inscription: 18-08-2012
Messages: 63
Site web

Re: Protection anti hotlink

Bonjour Cristal,

Hier soir j'ai de nouveau essayé sur un blog test (qui se trouve sur le serveur Odin), mais directement en activant la protection par le cPanel.
Et ça fonctionne très bien, effet immédiat, photos protégées et qui restent protégées.

Du coup pour mon blog(sur Gaia) j'ai appliqué la même méthode, en activant la protection directement par par le cPanel, et pour l'instant cela semble fonctionner correctement, toutes celles qui sont sur picstopin renvoie bien sur mon blog, et ne s'affiche pas sur picstopin.

Exemple sur cette page:
http://www.picstopin.com/500/amazone-fr … u_001*jpg/
Les deux photos d'Amazones à front bleu 1440x .

Par contre le tuto de Aube Nature m’intéresse beaucoup, surtout la partie script en bas du tuto.
Je vais d'abord l'essayer sur le blog test avant.
Ceci dit j'ai également vu une photo de Aube Nature sur picstopin qui s'affiche en grand, la protection 100% n'existe sans doute pas, à part ne rien publier!!!
Donc pour résumer, après avoir repris la protection par le cPanel, hier soir ça fonctionnait et ça fonctionne encore actuellement, une photo publiée est immédiatement protégée, ce n'était pas le cas avant.Et je teste le tuto de Aube Nature dans la foulée.

Pour info j'avais obtenu le code du .htacess par ce site:
http://www.htaccesstools.com/hotlink-protection/
Merci.

Bon week end.

Hors ligne

 

#6 14-03-2014 15:26:35

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5038
Site web

Re: Protection anti hotlink

Bonjour,

Alors, vous avez essayez différentes solutions ? notamment celle présentée dans le lien que je vous avais donné ?


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

#7 15-03-2014 09:21:00

gilbert290
Membre
Date d'inscription: 18-08-2012
Messages: 63
Site web

Re: Protection anti hotlink

Bonjour,

Oui oui, j'ai essayé pas mal de choses, mais finalement j'arrive toujours au même résultat, au test beaucoup de photos ne semble pas protégées et elles s'affichent normalement sur picstopin.

Par contre un chose que je n'avais pas remarqué avant, au test une photo qui s'affiche disparait en faisant Ctrl F5 au clavier, idem sur picstopin, une photo qui s'affiche  disparait par Ctrl F5, et c'est valable pour n'importe quelle méthode ou code utilisé dans le .htaccess.

J'ai essayé un plugin wordpress qui me plaisait bien:
https://wordpress.org/plugins/byrev-wp- … k-defence/
Il remplaçait l'image hotlinkée par une autre image sur picstopin, mais le problème c'est que l'image originale était remplacé également sur le blog, et la également Ctrl F5 la faisait apparaitre sur mon blog, et idem beaucoup de photos ne semblaient pas protégées, et le devenaient par Ctrl F5.

Sur la description du plugin il y a marqué ceci:
Before Install: Some incompatibility with Varnish, Lighthttpd, and other "cache" services - Images must not be cached !!!

Gaia tourne avec Varnish il me semble.

A noter que sur Odin je ne retrouve pas le même fonctionnement, tout fonctionne directement sans faire Ctrl F5.

L'utilisation de Ctrl F5 vide le cache su serveur il me semble, ce phénomène ce produit pour tout le monde ou seulement pour mon adresse IP?

Est qu'il y a un problème avec le cache, ou c'est finalement un fonctionnement tout à fait normal?

Une autre petite question, picstopin se débrouille comment pour hotlinkée mes photos, un robot?
Ils ont probablement aspiré le site en entier!!

Merci d'avance et bon week end sous ce beau temps printanier.

Dernière modification par gilbert290 (15-03-2014 09:22:17)

Hors ligne

 

#8 17-03-2014 11:59:34

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5038
Site web

Re: Protection anti hotlink

Bonjour,

Il y a le cache du navigateur qui est vidé quand vous faites ctrl + F5, c'est uniquement sur votre ordinateur.
Le cache serveur se gère tout seul, les fichiers statiques sont gardées 30 minutes sur Varnish.

Je peux désactiver ce cache serveur pour votre site si vous le voulez.


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

#9 17-03-2014 12:20:16

gilbert290
Membre
Date d'inscription: 18-08-2012
Messages: 63
Site web

Re: Protection anti hotlink

Bonjour,

Oui vous pouvez le désactiver pour quelques jours, le temps de voir si cela change quelque chose.
Merci beaucoup.
Bonne journée.

Hors ligne

 

#10 18-03-2014 13:59:43

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5038
Site web

Re: Protection anti hotlink

Normalement c'est bon pour que le site ne soit pas diffusé via Varnish.


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

#11 30-03-2014 10:33:29

gilbert290
Membre
Date d'inscription: 18-08-2012
Messages: 63
Site web

Re: Protection anti hotlink

Bonjour,

Quelques nouvelles, en fait tout fonctionne très bien, je pense que c'est ma mauvaise interprétation du cache qui était en cause.
J'ai mis un petit message en remplacement des photos hotlinkées, et ça fonctionne également très bien.
Donc problème résolu pour moi.
Merci et bon dimanche.

Hors ligne

 

#12 02-04-2014 00:37:51

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5038
Site web

Re: Protection anti hotlink

Ok smile


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB
Traduction par FluxBB.fr