Forum Archive-Host

Vous n'êtes pas identifié.

#1 23-08-2012 22:42:00

spookyfr
Membre
Date d'inscription: 22-08-2012
Messages: 17

Fonction "Partager par mail"; erreur 403 pour le destinataire.

Bonjour,

J'ai tenté d'utiliser la fonction "Partager par mail" pour envoyer deux liens de fichier PDF à un correspondant. Les liens apparaissent bien dans le mail mais le destinataire a une erreur 403 Forbiten quand il essaye d'ouvrir ou d'enregistrer ces documents.
J'ai essayé de créer des liens permanents pour ces deux fichiers mais ça na rien changé (l'envoi de lien avec la fonction mail envoie toujours des liens en /members/ au lieu de /link/ )
J'ai envoyé un lien sur une autre machine du boulot et même problème.
Si il y avait un moyen de contourner ça, ça serait super !

Et a propos, il existe d'autres balises que {URL} et {LIEN_FICHIERS} pour la création des modèles ?

Merci !

Spk

Hors ligne

 

#2 23-08-2012 23:19:03

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5039
Site web

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

Bonsoir,

Le lien envoyé est complet ?
Ca le fait avec quel fichier par exemple ?

Il n'y a que ces balises pour le moment, si vous en souhaitez d'autres je peux voir ça.

Vous pourriez m'envoyer un mail sur mon adresse (techniqueATarchive-host.com) que je vérifie ?


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

#3 24-08-2012 09:27:03

spookyfr
Membre
Date d'inscription: 22-08-2012
Messages: 17

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

Merci pour cette réponse.

Je suppose que le lien est bien complet car j'utilise la fonction "Partager par mail" pour l'envoyer.
Je vous envoi un exemple au mail que vous m'avez indiqué, je viens de tester à nouveau ce matin et j'ai toujours le même problème.
Vous retrouverez mon message avec l'entête : "Essai download fichiers TM-WW2"

Quant aux balises, j'ouvrirai un post dans la section suggestions.

Merci !
Spk

Hors ligne

 

#4 24-08-2012 10:47:41

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5039
Site web

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

Bonjour,

J'ai aussi eu les erreurs 403.
Si on recharge la page le fichier apparaît bien à ce moment là.

J'ai fait une petite modification dans la configuration du serveur web (le seul endroit qui touche aux fichiers pdf), vous me direz ce que cela donne.
Essayez avec d'autres types de fichiers que PDF pour vérifier mais a priori ça serait plus lié au fait que ça soit des PDF.


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

#5 24-08-2012 11:12:55

spookyfr
Membre
Date d'inscription: 22-08-2012
Messages: 17

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

Je viens de faire des tests et ça marche nickel maintenant !

Un grand merci pour la rapidité d'intervention. on peut modifier le titre de mon message en [resolu]

Spk

Dernière modification par spookyfr (24-08-2012 11:14:29)

Hors ligne

 

#6 24-08-2012 11:26:27

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5039
Site web

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

Vous êtes sur quel navigateur ?
Bizarre quand même, c'est pas censé faire ça... C'était un paramètre pour mieux gérer le téléchargement des fichiers PDF.


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

#7 24-08-2012 11:32:20

spookyfr
Membre
Date d'inscription: 22-08-2012
Messages: 17

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

J'avais testé sur Firefox 14.1 et IE 9.0.8112 (seven pro 64bit)
Par contre, je ne connais pas les browsers de mes deux clients qui ont rencontré le problème.

Spk

Hors ligne

 

#8 24-08-2012 11:40:23

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5039
Site web

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

Bon on verra ce que cela donne.


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

#9 24-08-2012 12:00:55

spookyfr
Membre
Date d'inscription: 22-08-2012
Messages: 17

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

J'ai eu un message de mes clients, ça marche pour eux aussi !

Encore merci
Spk

Hors ligne

 

#10 24-08-2012 13:19:02

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5039
Site web

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

Ok, je cherche ce qui c'est passé de mon côté.


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

#11 29-08-2012 20:00:51

spookyfr
Membre
Date d'inscription: 22-08-2012
Messages: 17

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

Étrangement, ça a bien marché quelques jours et le problème réapparait. Je le constate a l'instant. J'ai l'erreur 403, mais si je rentre dans le dossier via le panel, je peux a nouveau télécharger mon PDF via le link envoyé par mail ! (le même qui ne marchait pas 5s avant...)

Les liens permanents ne semblent pas affectés par ce soucis. Ne serait-il pas possible de contourner le problème en envoyant des liens permanents dans les balises  {URL} et {LIEN_FICHIERS} ?

Spk

Hors ligne

 

#12 30-08-2012 00:12:25

Cristal
Administrateur
Lieu: Dijon
Date d'inscription: 24-09-2006
Messages: 5039
Site web

Re: Fonction "Partager par mail"; erreur 403 pour le destinataire.

Je prévois ça dans la mise à jour du module, normalement je m'en occupe dans les jours qui viennent.
Sinon il faut recharger plusieurs fois la page mais même, ça ne le faisait pas avant...

Je vais fouiller pour voir, mais j'ai rien de concret dans les logs hmm


Cristal
Directeur d'Archive-Host

État du Reseau

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB
Traduction par FluxBB.fr